Skip to main content
VulnerabilityPublished Updated

CVE-2026-24422: thorsten phpMyFAQ · Information Exposure

Affects thorsten phpMyFAQSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.0.17 when convenient.

Data as of 26 Oct 2026, 11:07 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.17
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade phpMyFAQ and thorsten/phpMyFAQ to 4.0.17.

Affected software

ProductAffectedFixed in
thorstenphpMyFAQAffected
  • <4.0.17
Fixed in
  • 4.0.17
GitHubthorsten/phpMyFAQpkg:github/thorsten/phpMyFAQOther threatsAffected
  • <4.0.17
Fixed in
  • 4.0.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade phpMyFAQ installations to version 4.0.17 or later, where the vulnerability is patched. If immediate upgrade is not feasible, restrict access to phpMyFAQ API endpoints by implementing network-level controls such as IP whitelisting or VPN access to limit exposure. Review and audit API access logs for suspicious activity indicating data harvesting attempts. Disable or restrict public API endpoints that are not essential. Implement web application firewalls (WAF) with custom rules to detect and block anomalous API requests targeting the affected endpoints. Conduct a thorough review of user data exposure and notify affected users if email addresses were compromised, following GDPR breach notification requirements.

Description

phpMyFAQ is an open source FAQ web application. In versions 4.0.16 and below, multiple public API endpoints improperly expose sensitive user information due to insufficient access controls. The OpenQuestionController::list() endpoint calls Question::getAll() with showAll=true by default, returning records marked as non-public (isVisible=false) along with user email addresses, with similar exposures present in comment, news, and FAQ APIs. This information disclosure vulnerability could enable attackers to harvest email addresses for phishing campaigns or access content that was explicitly marked as private. This issue has been fixed in version 4.0.17.

References

Community reviews

Loading reviews…