CVE-2026-24457: Eclipse OpenMQ · Path Traversal
Affects Eclipse OpenMQSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 6.9.0 or 6.5.2 as a priority.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.9.0, 6.5.2, 8.0.2 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Eclipse to 6.9.0 or 6.5.2 (OpenMQ); 8.0.2, 7.1.1 or 7.0.26 (GlassFish).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Eclipse FoundationEclipse OpenMQ | Affected
| Fixed in
|
| Eclipse FoundationEclipse OpenMQ | Affected
| Fixed in
|
| Eclipse FoundationEclipse GlassFish | Affected
| Fixed in
|
| Eclipse FoundationEclipse GlassFish | Affected
| Fixed in
|
| Eclipse FoundationEclipse GlassFish | Affected
| Fixed in
|
Mavenorg.eclipse.openmq/openmqpkg:maven/org.eclipse.openmq/openmqOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in Eclipse OpenMQ versions 6.5.2 and 6.9.0, and in GlassFish versions 7.0.26, 7.1.1, and 8.0.2. Users should upgrade to these fixed versions to remediate the issue. No other mitigations are indicated by the vendor advisory. Patch status is confirmed by the vendor advisory.
Description
An unsafe parsing of OpenMQ's configuration in OpenMQ versions <6.5.2 and <6.9.0, allows a remote attacker to read arbitrary files from a MQ Broker's server. A full exploitation could read unauthorized files of the OpenMQ’s host OS. In some scenarios RCE could be achieved. This is fixed in OpenMQ 6.5.2, 6.9.0, and in GlassFish 7.0.26, 7.1.1, and 8.0.2.