Skip to main content
CVE-2026-24671VulnerabilityPublished

CVE-2026-24671: gunet openeclass · Cross-site Scripting

Affects gunet openeclassSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 4.2 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade openeclass and gunet/openeclass to 4.2.

Affected software

ProductAffectedFixed in
gunetopeneclassAffected
  • <4.2
Fixed in
  • 4.2
GitHubgunet/openeclasspkg:github/gunet/openeclassOther threatsAffected
  • <4.2
Fixed in
  • 4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade Open eClass installations to version 4.2 or later, where the vulnerability has been patched. Until upgrades are completed, restrict high-privileged user access to trusted personnel only and monitor for unusual activity indicative of attempted script injection. Implement Content Security Policy (CSP) headers to limit the execution of unauthorized scripts within the application context. Conduct regular security training for administrators and teachers to raise awareness about the risks of injecting untrusted content. Employ web application firewalls (WAFs) configured to detect and block XSS payloads targeting known vulnerable input fields. Review and sanitize all user inputs rigorously, even from trusted users, to prevent injection of malicious code. Regularly audit logs for signs of suspicious input or script execution. Finally, ensure that incident response plans include procedures for handling XSS incidents in educational platforms.

Description

CVE-2026-24671 is a stored Cross-Site Scripting (XSS) vulnerability affecting Open eClass versions prior to 4.2. It allows authenticated high-privileged users, such as teachers or administrators, to inject malicious JavaScript into multiple user-controllable input fields. This malicious script executes when other users access the affected pages, potentially compromising confidentiality and integrity. The vulnerability requires authentication with high privileges and user interaction to trigger the payload. It has a CVSS score of 6.1, indicating medium severity, and has been patched in version 4.2. No known exploits are currently reported in the wild. European educational institutions using Open eClass versions below 4.

References

Community reviews

Loading reviews…