CVE-2026-24788: raspap-webgui · OS Command Injection
Affects raspap-webguiSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 3.3.6 soon.
Data as of 26 Oct 2026, 09:16 UTC
- EPSS
- 1.3% chance of exploitation in 30 days – higher than 71% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.3.6
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade raspap/raspap-webgui to 3.3.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RaspAPraspap-webgui | Affected
| Fixed in– |
GitHubraspap/raspap-webguipkg:github/raspap/raspap-webguiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2026-24788, organizations should immediately upgrade all raspap-webgui installations to version 3.3.6 or later, where the vulnerability has been addressed. Restrict access to the web interface by enforcing strong authentication mechanisms and limiting login privileges to trusted administrators only. Implement network segmentation to isolate Raspberry Pi devices from critical network segments, reducing the risk of lateral movement if compromised. Monitor logs and network traffic for unusual command execution patterns or unauthorized access attempts. Employ application-layer firewalls or intrusion detection systems capable of detecting command injection attempts. Regularly audit and update all embedded device software to ensure timely application of security patches. Educate administrators on secure configuration practices for RaspAP and the risks associated with command injection vulnerabilities. Finally, consider disabling or restricting features that allow command execution from the web interface if not required.
Description
CVE-2026-24788 is a high-severity OS command injection vulnerability in raspap-webgui versions prior to 3.3.6. It allows an authenticated user with login access to execute arbitrary OS commands due to improper neutralization of special elements. The vulnerability has a CVSS score of 8.8, indicating critical impacts on confidentiality, integrity, and availability without requiring user interaction. Exploitation could lead to full system compromise of devices running the vulnerable RaspAP web interface. Although no known exploits are currently reported in the wild, the ease of exploitation and potential damage make timely patching essential. European organizations using RaspAP for wireless access point management, especially in sectors relying on Raspberry Pi devices, are at risk. Countries with higher adoption of Raspberry Pi-based network solutions and critical infrastructure deployments are more likely to be affected.