Skip to main content
CVE-2026-24807VulnerabilityPublished Updated

CVE-2026-24807: liuyueyi quick-media · Improper Verification of Cryptographic Signature

Affects liuyueyi quick-mediaSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to v1.0 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in v1.0, 1.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/S:N/AU:Y/R:U/V:C/RE:M/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade quick-media to v1.0; liuyueyi/quick-media and quick-media to 1.0.

Affected software

ProductAffectedFixed in
liuyueyiquick-mediaAffected
  • <1.0
Fixed in
  • v1.0
GitHubliuyueyi/quick-mediapkg:github/liuyueyi/quick-mediaOther threatsAffected
  • <1.0
Fixed in
  • 1.0
GitHubquick-mediapkg:github/quick-mediaOther threatsAffected
  • <1.0
Fixed in
  • 1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, cautious use of the affected components is advised, especially in security-critical contexts.

Description

Improper Verification of Cryptographic Signature vulnerability in liuyueyi quick-media (plugins/svg-plugin/batik-codec-fix/src/main/java/org/apache/batik/ext/awt/image/codec/util modules). This vulnerability is associated with program files SeekableOutputStream.Java. This issue affects quick-media: before v1.0.

References

Community reviews

Loading reviews…