Skip to main content
CVE-2026-24833VulnerabilityPublished

CVE-2026-24833: dnnsoftware Dnn.Platform · Cross-site Scripting

Affects dnnsoftware Dnn.PlatformSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High : upgrade to 10.2.0 or 9.13.10 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2.0, 9.13.10, 10.2.1
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade Dnn.Platform to 10.2.0 or 9.13.10; dnnsoftware/Dnn.Platform to 10.2.1 or 9.13.10.

Affected software

ProductAffectedFixed in
dnnsoftwareDnn.PlatformAffected
  • <9.13.10
  • >=10.0.0 <10.2.0
Fixed in
  • 10.2.0
  • 9.13.10
GitHubdnnsoftware/Dnn.Platformpkg:github/dnnsoftware/Dnn.PlatformOther threatsAffected
  • <9.13.10
  • >=10.0.0 <10.2.1
Fixed in
  • 9.13.10
  • 10.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade all affected Dnn.Platform installations to versions 9.13.10 or 10.2.0 or later, where the vulnerability is patched. Beyond patching, organizations should enforce strict role-based access controls to limit module installation and modification privileges to trusted administrators only. Implementing comprehensive input validation and output encoding on all user-supplied content fields, especially richtext inputs, will reduce the risk of similar vulnerabilities. Deploying Content Security Policy (CSP) headers can help mitigate the impact of potential XSS attacks by restricting script execution sources. Regular security audits and penetration testing focused on the Persona Bar and module management interfaces are recommended to detect any residual or new vulnerabilities. Monitoring logs for unusual module installation or modification activities can provide early detection of exploitation attempts. Finally, educating administrators about the risks of installing untrusted modules and the importance of applying security updates promptly is essential.

Description

CVE-2026-24833 is a high-severity cross-site scripting (XSS) vulnerability in the Dnn. Platform CMS affecting versions prior to 9.13.10 and between 10.0.0 and 10.2.0. The flaw allows malicious scripts embedded in a module's richtext description field to execute within the Persona Bar interface, potentially compromising confidentiality, integrity, and availability. Exploitation requires authenticated access with high privileges and user interaction, but can lead to full session compromise and persistent code execution.

References

Community reviews

Loading reviews…