Skip to main content
VulnerabilityPublished

CVE-2026-24837: dnnsoftware Dnn.Platform · Cross-site Scripting

Affects dnnsoftware Dnn.PlatformSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High : upgrade to 10.2.0 or 9.13.10 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2.0, 9.13.10
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Dnn.Platform to 10.2.0 or 9.13.10; dnnsoftware/Dnn.Platform to 9.13.10.

Affected software

ProductAffectedFixed in
dnnsoftwareDnn.PlatformAffected
  • >=10.0.0 <10.2.0
Fixed in
  • 10.2.0
dnnsoftwareDnn.PlatformAffected
  • >=9.0.0 <9.13.10
Fixed in
  • 9.13.10
GitHubdnnsoftware/Dnn.Platformpkg:github/dnnsoftware/Dnn.PlatformOther threatsAffected
  • >=9.0.0 <9.13.10
  • =10.2.0
Fixed in
  • 9.13.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately assess their Dnn.Platform versions and upgrade to 9.13.10 or 10.2.0 or later to remediate this vulnerability. In the interim, restrict access to the Persona Bar and module management interfaces to only trusted administrators and monitor for unusual activity. Implement Content Security Policy (CSP) headers to reduce the impact of potential XSS exploitation. Conduct regular security training to reduce the risk of social engineering that could facilitate exploitation. Employ web application firewalls (WAFs) with rules tuned to detect and block suspicious script injections targeting module friendly names. Review and harden user privilege assignments to minimize the number of users with high-level access. Finally, perform routine security audits and penetration testing focusing on CMS components to detect similar injection flaws.

Description

CVE-2026-24837 is a high-severity cross-site scripting (XSS) vulnerability in the Dnn. Platform CMS affecting versions from 9.0.0 up to but not including 9.13.10 and 10.2.0. The flaw arises because module friendly names can contain malicious scripts that execute during certain Persona Bar module operations. Exploitation requires authenticated users with high privileges and some user interaction, but can lead to complete compromise of confidentiality, integrity, and availability due to the scope of the vulnerability.

References

Community reviews

Loading reviews…