CVE-2026-24838: dnnsoftware Dnn.Platform · Cross-site Scripting
Affects dnnsoftware Dnn.PlatformSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 10.2.0 or 9.13.10 as a priority.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.2.0, 9.13.10
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade Dnn.Platform to 10.2.0 or 9.13.10; dnnsoftware/Dnn.Platform to 9.13.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| dnnsoftwareDnn.Platform | Affected
| Fixed in
|
GitHubdnnsoftware/Dnn.Platformpkg:github/dnnsoftware/Dnn.PlatformOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately verify their Dnn.Platform versions and upgrade to 9.13.10 or 10.2.0 or later to apply the official patch. In addition to patching, organizations should audit all module titles and rich text inputs for malicious content and implement strict input validation and output encoding as defense-in-depth measures. Employing web application firewalls (WAFs) with custom rules to detect and block suspicious script injections can provide temporary protection. Limit administrative privileges and enforce strong authentication mechanisms to reduce the risk of credential compromise. Regularly monitor logs for unusual activities related to module title changes or script injections. Conduct security awareness training for administrators to recognize and prevent misuse of CMS features. Finally, maintain an incident response plan tailored for web application attacks to quickly contain and remediate any exploitation attempts.
Description
CVE-2026-24838 is a critical cross-site scripting (XSS) vulnerability in the Dnn. Platform CMS affecting versions prior to 9.13.10 and between 10.0.0 and 10.2.0. The issue arises because module titles support rich text input that can include malicious scripts, which execute in certain scenarios without user interaction. Exploitation requires authenticated access but can lead to complete compromise of confidentiality, integrity, and availability of affected systems.