Skip to main content
VulnerabilityPublished

CVE-2026-24884: node-modules compressing · Link Following

Affects node-modules compressingSource CVE Database V5

0

Not known to be exploited · CVSS 8.4 High : upgrade to 1.10.4 soon.

Data as of 26 Oct 2026, 09:08 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.10.4
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade node-modules compressing to 1.10.4.

Affected software

ProductAffectedFixed in
node-modulescompressingAffected
  • <1.10.4
  • =2.0.0
Fixed in
  • 1.10.4
npmcompressingpkg:npm/compressingOther threatsAffected
  • =2.0.0
  • <1.10.4
Fixed in
  • 1.10.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately audit their software dependencies to identify usage of the 'compressing' library versions 2.0.0 or any version prior to 1.10.4. They must upgrade to version 1.10.4 or 2.0.1 or later where the vulnerability is patched. Additionally, implement strict input validation and sandboxing for archive extraction processes to restrict file writes to intended directories. Employ runtime monitoring to detect anomalous file system changes during extraction. Where upgrading is not immediately feasible, consider isolating the extraction process in containers or virtual machines with limited permissions to minimize potential damage. Security teams should also review logs for suspicious extraction activities and educate developers about secure handling of archive files. Incorporating static and dynamic analysis tools to detect unsafe archive extraction patterns in codebases can prevent future vulnerabilities of this nature.

Description

CVE-2026-24884 is a high-severity vulnerability in the node-modules 'compressing' library versions 2.0.0 and prior to 1.10.4. The flaw involves improper link resolution during TAR archive extraction, where symbolic links are restored without validating their targets. This allows attackers to craft archives with symlinks pointing outside the intended extraction directory, enabling arbitrary file writes or overwrites on the host system. Exploitation can lead to full confidentiality, integrity, and availability compromise without requiring authentication or user interaction. The vulnerability has been patched in versions 1.10.

References

Community reviews

Loading reviews…