CVE-2026-24907: octobercms october · Cross-site Scripting
Affects octobercms octoberSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 4.1.10 or 3.7.14 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.10, 3.7.14
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade october to 4.1.10 or 3.7.14; octobercms/october to 3.7.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| octobercmsoctober | Affected
| Fixed in
|
| octobercmsoctober | Affected
| Fixed in
|
GitHuboctobercms/octoberpkg:github/octobercms/octoberOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in OctoberCMS versions 3.7.14 and 4.1.10; users should upgrade to these or later versions to fully remediate the vulnerability. For those unable to update immediately, it is recommended to restrict mail template editing permissions to fully trusted administrators and limit Event Log viewing permissions to reduce exposure to the vulnerability.
Description
October is a Content Management System (CMS) and web platform. Versions prior to 3.7.14 and 4.1.10 contain a stored cross-site scripting (XSS) vulnerability in the Event Log mail preview feature. When viewing logged mail messages, HTML content was rendered in an iframe without proper sandboxing, allowing JavaScript execution in the viewer's browser context. This issue has been fixed in versions 3.7.14 and 4.1.10. If users are unable to update immediately, workarounds include restricting mail template editing permissions to fully trusted administrators only and restricting Event Log viewing permissions to minimize exposure.