Skip to main content
CVE-2026-24942VulnerabilityPublished Updated

CVE-2026-24942: WpEvently (WordPress plugin) · Cross-Site Request Forgery (CSRF)

Affects WpEvently (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 4.3 Medium : upgrade to 5.1.2 when convenient.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.1.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade WpEvently (WordPress plugin) to 5.1.2.

Affected software

ProductAffectedFixed in
magepeopleteamWpEventlyAffected
  • <5.1.2
Fixed in
  • 5.1.2

AI-suggested

If you cannot patch yet, users should consider applying standard CSRF mitigations such as disabling or restricting the plugin if feasible, or limiting user roles that can interact with it.

Description

Cross-Site Request Forgery (CSRF) vulnerability in magepeopleteam WpEvently mage-eventpress allows Cross Site Request Forgery.This issue affects WpEvently: from n/a through <= 5.1.1.

References

Community reviews

Loading reviews…