Skip to main content
CVE-2026-25024VulnerabilityPublished Updated

CVE-2026-25024: ThirstyAffiliates (WordPress plugin) · Cross-Site Request Forgery (CSRF)

Affects ThirstyAffiliates (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium : upgrade to 3.11.10 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.11.10
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade ThirstyAffiliates (WordPress plugin) to 3.11.10.

Affected software

ProductAffectedFixed in
Blair WilliamsThirstyAffiliatesAffected
  • <3.11.10
Fixed in
  • 3.11.10

AI-suggested

If you cannot patch yet, users should consider implementing CSRF protections such as verifying request origins or using anti-CSRF tokens if possible.

Description

Cross-Site Request Forgery (CSRF) vulnerability in Blair Williams ThirstyAffiliates thirstyaffiliates allows Cross Site Request Forgery.This issue affects ThirstyAffiliates: from n/a through <= 3.11.9.

References

Community reviews

Loading reviews…