CVE-2026-25141: orval · Code Injection
Affects orvalSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 9.3 Critical : upgrade to 8.2.0 or 7.21.0 as a priority.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.2.0, 7.21.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade orval to 8.2.0 or 7.21.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| orval-labsorval | Affected
| Fixed in
|
| orval-labsorval | Affected
| Fixed in
|
AI-suggested
To mitigate CVE-2026-25141, European organizations should immediately upgrade orval to versions 7.21.0 or 8.2.0, which contain the updated fix addressing the code injection vulnerability. It is critical to audit all generated client code for suspicious patterns or injection attempts, especially if older versions were used recently. Incorporate static code analysis tools capable of detecting code injection risks in generated code. Review and harden CI/CD pipelines to ensure that only sanitized and verified OpenAPI specifications are processed by orval. Implement strict input validation and sanitization on all OpenAPI/Swagger specifications before client generation. Where possible, isolate orval-generated clients in sandboxed environments to limit the impact of potential exploitation. Monitor network traffic and application logs for anomalous JavaScript execution or injection indicators. Educate development teams about the risks of code injection and the importance of using updated tooling. Finally, maintain an inventory of software dependencies to quickly identify and remediate vulnerable versions of orval in use.
Description
Orval generates type-safe JS clients (TypeScript) from any valid OpenAPI v3 or Swagger v2 specification. Versions starting with 7.19.0 and prior to 7.21.0 and 8.2.0 have an incomplete fix for CVE-2026-23947. While the jsStringEscape function properly handles single quotes ('), double quotes (") and so on, it is still possible to achieve code injection using only a limited set of characters that are currently not escaped. The vulnerability lies in the fact that the application can be forced to execute arbitrary JavaScript using characters such as []()!+. By using a technique known as JSFuck, an attacker can bypass the current sanitization logic and run arbitrary code without needing any alphanumeric characters or quotes. Version 7.21.0 and 8.2.0 contain an updated fix.
References
- github.com/orval-labs/orval/security/advisories/GHSA-gch2-phqh-fg9q (opens in a new tab)
- github.com/orval-labs/orval/security/advisories/GHSA-h526-wf6g-67jv (opens in a new tab)
- github.com/orval-labs/orval/blob/02211fc413524be340ba9ace866a2ef68845ca7c/packages/core/src/utils/string.ts (opens in a new tab)
- github.com/orval-labs/orval/releases/tag/v7.21.0 (opens in a new tab)
- github.com/orval-labs/orval/releases/tag/v8.2.0 (opens in a new tab)