CVE-2026-25148: QwikDev qwik · Cross-site Scripting
Affects QwikDev qwikSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.19.0 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.19.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade qwik and qwikdev/qwik to 1.19.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| QwikDevqwik | Affected
| Fixed in
|
npmqwikdev/qwikpkg:npm/qwikdev/qwikOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Upgrade all Qwik framework instances to version 1.19.0 or later immediately to apply the official patch addressing this vulnerability.
- Conduct a thorough audit of server-side rendering code to identify any custom serialization or handling of virtual attributes that may bypass framework protections.
- Implement Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts and mitigate the impact of potential XSS attacks.
- Employ input validation and output encoding best practices in all web application components, especially those interacting with user-supplied data.
- Monitor web application logs and user reports for suspicious activity indicative of XSS exploitation attempts.
- Educate developers on secure coding practices related to server-side rendering and JavaScript frameworks to prevent similar vulnerabilities.
- Consider using automated security scanning tools that can detect XSS vulnerabilities in web applications during development and deployment cycles.
- If immediate upgrade is not feasible, apply temporary mitigations such as disabling server-side rendering of virtual attributes or sanitizing inputs at the application layer.
Description
CVE-2026-25148 is a medium severity Cross-Site Scripting (XSS) vulnerability in Qwik, a JavaScript framework focused on performance. Versions prior to 1.19.0 are affected due to improper neutralization of input during server-side rendering of virtual attributes, allowing remote attackers to inject malicious scripts. Exploitation requires no authentication but does require user interaction to trigger script execution in the victim's browser within the affected origin context. This vulnerability can lead to theft of sensitive information, session hijacking, or other malicious actions performed on behalf of the user. The issue has been patched in Qwik version 1.19.0. European organizations using affected Qwik versions in web applications are at risk, especially those with public-facing services.