CVE-2026-25230: error311 FileRise · Cross-site Scripting
Affects error311 FileRiseSource CVE Database V5
Not known to be exploited · CVSS 4.6 Medium : upgrade to 3.3.0 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.3.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 9 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade error311 FileRise to 3.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| error311FileRise | Affected
| Fixed in
|
AI-suggested
European organizations should immediately upgrade all FileRise instances to version 3.3.0 or later to remediate this vulnerability. Until upgrades are completed, implement strict access controls to limit authenticated user privileges, ensuring only trusted users have write or administrative access. Employ web application firewalls (WAFs) with custom rules to detect and block suspicious HTML injection attempts. Conduct regular audits of user accounts and session activities to identify unusual behavior. Additionally, educate users about the risks of interacting with unexpected or suspicious interface elements, emphasizing caution with links and forms within the application. Consider network segmentation to isolate FileRise servers from broader enterprise networks, reducing the risk of lateral movement if an account is compromised.
Description
CVE-2026-25230 is a medium severity cross-site scripting (XSS) vulnerability affecting FileRise versions prior to 3.3.0. It allows an authenticated user to inject HTML elements into the web interface, potentially modifying the DOM to include malicious forms or links that could redirect users or trigger unwanted actions upon interaction. Exploitation requires authentication and user interaction, limiting its impact to users with access to the system. The vulnerability does not compromise confidentiality but can affect integrity and availability by manipulating the web interface. This issue has been fixed in FileRise version 3.3.0. European organizations using vulnerable versions should prioritize upgrading and implement strict access controls to mitigate risks.
References
- github.com/error311/FileRise/security/advisories/GHSA-h8fw-42v6-gfhv (opens in a new tab)
- github.com/error311/FileRise/blob/7fee135a5b8feb25558aba0474bd6bb53943fc88/src/controllers/FileController.php (opens in a new tab)
- github.com/error311/FileRise/blob/7fee135a5b8feb25558aba0474bd6bb53943fc88/src/models/FileModel.php (opens in a new tab)
- github.com/error311/FileRise/releases/tag/v3.3.0 (opens in a new tab)