Skip to main content
CVE-2026-25237VulnerabilityPublished Updated

CVE-2026-25237: pear pearweb · Executable Regular Expression Error

Affects pear pearwebSource CVE Database V5

0

Not known to be exploited · CVSS 9.2 Critical : upgrade to 1.33.0 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.33.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade pear pearweb to 1.33.0.

Affected software

ProductAffectedFixed in
pearpearwebAffected
  • <1.33.0
Fixed in
  • 1.33.0

AI-suggested

1. Immediately upgrade pearweb to version 1.33.0 or later, where the vulnerability is patched. 2. Audit all PHP codebases for usage of preg_replace() with the /e modifier or similar constructs that evaluate user input, and refactor to use safer alternatives such as preg_replace_callback(). 3. Implement strict input validation and sanitization for any data processed by regular expressions or evaluated code paths. 4. Employ web application firewalls (WAFs) with custom rules to detect and block suspicious payloads targeting this vulnerability. 5. Monitor logs for unusual activity related to bug update email handling or unexpected PHP code execution. 6. Conduct penetration testing focusing on injection vectors in PHP applications using pearweb components. 7. Educate development teams on secure PHP coding practices to avoid deprecated and unsafe functions. 8. Maintain an up-to-date inventory of PHP components and dependencies to ensure timely patching. 9. Restrict permissions of PHP processes to minimize impact if exploitation occurs. 10. Consider network segmentation to isolate critical systems running vulnerable PHP applications.

Description

CVE-2026-25237 is a critical vulnerability in pearweb, a component of the PEAR PHP framework, affecting versions prior to 1.33.0. It arises from the use of preg_replace() with the deprecated /e modifier, which allows attacker-controlled input to be evaluated as PHP code during bug update email handling. This leads to remote code execution without requiring authentication or user interaction. The vulnerability has a CVSS 4.0 score of 9.2, indicating high impact on confidentiality, integrity, and availability. Although no known exploits are currently reported in the wild, the ease of exploitation and severity make it a significant threat. European organizations using pearweb in their PHP environments are at risk, especially those in sectors relying on legacy PHP components.

References

Community reviews

Loading reviews…