CVE-2026-25241: pear pearweb · SQL Injection
Affects pear pearwebSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.33.0 as a priority.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.33.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade pear pearweb to 1.33.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pearpearweb | Affected
| Fixed in
|
AI-suggested
European organizations should immediately upgrade all pearweb instances to version 1.33.0 or later to apply the official patch. In addition to patching, implement strict input validation and sanitization on all user-supplied data, especially parameters used in SQL queries. Employ parameterized queries or prepared statements to prevent injection attacks. Conduct thorough code reviews and security testing focusing on SQL injection vectors. Monitor web server and database logs for unusual query patterns or repeated access attempts to the /get/<package>/<version> endpoint. Deploy Web Application Firewalls (WAFs) with rules designed to detect and block SQL injection attempts targeting pearweb endpoints. Educate development and operations teams about secure coding practices and the importance of timely patch management. Finally, maintain an inventory of all PHP components and dependencies to quickly identify and remediate vulnerable versions.
Description
CVE-2026-25241 is a critical SQL injection vulnerability in the PEAR pearweb framework affecting versions prior to 1.33.0. It allows unauthenticated remote attackers to execute arbitrary SQL commands via the /get/<package>/<version> endpoint by manipulating the package version parameter. This vulnerability does not require authentication or user interaction and can lead to full compromise of the backend database, impacting confidentiality, integrity, and availability. Although no known exploits are currently in the wild, the high CVSS score of 9.3 reflects the severe risk. European organizations using pearweb in their PHP environments should urgently update to version 1.33.0 or later.