CVE-2026-25483: craftcms commerce · Cross-site Scripting
Affects craftcms commerceSource CVE Database V5
Not known to be exploited · CVSS 6.2 Medium : upgrade to 5.5.2 or 4.10.1 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.5.2, 4.10.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade craftcms commerce to 5.5.2 or 4.10.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| craftcmscommerce | Affected
| Fixed in
|
GitHubcraftcms/commercepkg:github/craftcms/commerceOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade Craft Commerce installations to versions 4.10.1 or later in the 4.x series, or 5.5.2 or later in the 5.x series, where the vulnerability is patched. Until patching is possible, restrict database backup utility permissions to trusted administrators only, and audit existing permissions to ensure no unnecessary users have this access. Implement strict input validation and sanitization on order status messages to prevent injection of malicious HTML or scripts. Employ Content Security Policy (CSP) headers to limit the execution of unauthorized scripts in the application context. Monitor logs for unusual activity related to order status messages and database backup operations. Conduct regular security assessments and penetration testing focused on web input handling and privilege management. Educate staff on the risks of XSS and the importance of least privilege principles. Finally, ensure robust incident response plans are in place to quickly address any suspected exploitation.
Description
CVE-2026-25483 is a stored cross-site scripting (XSS) vulnerability in Craft Commerce versions 4.0.0-RC1 to 4.10.0 and 5.0.0 to 5.5.1. The vulnerability arises from improper input neutralization in the Order Status History Message, which is rendered with a filter allowing raw HTML, enabling malicious script execution.
References
- github.com/craftcms/commerce/security/advisories/GHSA-8478-rmjg-mjj5 (opens in a new tab)
- github.com/craftcms/commerce/commit/4665a47c0961aee311a42af2ff94a7c470f0ad8c (opens in a new tab)
- github.com/craftcms/commerce/releases/tag/4.10.1 (opens in a new tab)
- github.com/craftcms/commerce/releases/tag/5.5.2 (opens in a new tab)