Skip to main content
VulnerabilityPublished Updated

CVE-2026-25487: craftcms commerce · Cross-site Scripting

Affects craftcms commerceSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 5.5.2 or 4.10.1 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.2, 4.10.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade commerce to 5.5.2 or 4.10.1; craftcms/commerce to 5.5.2.

Affected software

ProductAffectedFixed in
craftcmscommerceAffected
  • >=5.0.0 <5.5.2
Fixed in
  • 5.5.2
craftcmscommerceAffected
  • >=4.0.0-RC1 <4.10.1
Fixed in
  • 4.10.1
GitHubcraftcms/commercepkg:github/craftcms/commerceOther threatsAffected
  • >=5.0.0 <5.5.2
Fixed in
  • 5.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade Craft Commerce installations to versions 4.10.1 or 5.5.2 or later, where the vulnerability is patched. Until upgrades are possible, administrators should restrict access to the Store Management section to trusted personnel only and monitor for unusual activity. Input validation and sanitization should be enforced at the application level, especially for fields that are rendered in administrative interfaces. Implement Content Security Policy (CSP) headers to reduce the impact of potential XSS attacks by restricting the execution of unauthorized scripts. Conduct regular security audits and penetration testing focusing on administrative interfaces. Educate administrators about the risks of XSS and the importance of cautious interaction with user-generated content. Additionally, review logs for suspicious input in the Tax Rates 'Name' field and remove any suspicious entries. Employ multi-factor authentication (MFA) for administrative accounts to reduce the risk of credential compromise.

Description

CVE-2026-25487 is a stored cross-site scripting (XSS) vulnerability in Craft Commerce versions 4.0.0-RC1 to 4.10.0 and 5.0.0 to 5.5.1. The vulnerability arises from improper sanitization of the Tax Rates 'Name' field in the Store Management section, allowing attackers to inject malicious JavaScript that executes in an administrator's browser.

References

Community reviews

Loading reviews…