Skip to main content
CVE-2026-25488VulnerabilityPublished Updated

CVE-2026-25488: craftcms commerce · Cross-site Scripting

Affects craftcms commerceSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 5.5.2 or 4.10.1 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.2, 4.10.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade commerce to 5.5.2 or 4.10.1; craftcms/commerce to 5.5.2.

Affected software

ProductAffectedFixed in
craftcmscommerceAffected
  • >=4.0.0-RC1 <4.10.1
  • >=5.0.0 <5.5.2
Fixed in
  • 5.5.2
  • 4.10.1
GitHubcraftcms/commercepkg:github/craftcms/commerceOther threatsAffected
  • >=5.0.0 <5.5.2
Fixed in
  • 5.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade Craft Commerce to versions 4.10.1 or 5.5.2 or later to apply the official patch addressing this XSS vulnerability. Until patching is possible, organizations should restrict administrative access to trusted personnel only and implement network-level controls such as IP whitelisting or VPN access for the admin panel to reduce exposure. Additionally, enabling Content Security Policy (CSP) headers can help mitigate the impact of injected scripts by restricting script execution sources. Regularly auditing and sanitizing user-generated content in tax categories and other input fields can reduce the risk of malicious input. Monitoring administrative logs for unusual activity or unexpected changes to tax categories can provide early detection of exploitation attempts. Finally, educating administrators about the risks of clicking on suspicious links or viewing untrusted content within the admin panel can reduce the likelihood of successful exploitation.

Description

CVE-2026-25488 is a stored Cross-Site Scripting (XSS) vulnerability in Craft Commerce versions 4.0.0-RC1 to 4.10.0 and 5.0.0 to 5.5.1. The flaw arises from improper sanitization of the Tax Categories (Name & Description) fields in the Store Management admin panel, allowing attackers to inject malicious JavaScript that executes in an administrator's browser.

References

Community reviews

Loading reviews…