Skip to main content
VulnerabilityPublished

CVE-2026-25522: craftcms commerce · Cross-site Scripting

Affects craftcms commerceSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 5.5.2 or 4.10.1 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.2, 4.10.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade commerce to 5.5.2 or 4.10.1; craftcms/commerce to 5.5.2.

Affected software

ProductAffectedFixed in
craftcmscommerceAffected
  • >=5.0.0 <5.5.2
Fixed in
  • 5.5.2
craftcmscommerceAffected
  • >=4.0.0-RC1 <4.10.1
Fixed in
  • 4.10.1
GitHubcraftcms/commercepkg:github/craftcms/commerceOther threatsAffected
  • >=5.0.0 <5.5.2
Fixed in
  • 5.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade Craft Commerce installations to versions 4.10.1 or 5.5.2 or later, where the vulnerability is patched. Until upgrades can be performed, implement strict input validation and sanitization on all user-supplied data fields, especially those exposed in administrative interfaces. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in the admin panel. Limit administrative access to trusted networks and use multi-factor authentication to reduce the risk of credential compromise. Regularly audit and monitor admin panel activity for unusual behavior that could indicate exploitation attempts. Educate administrators about the risks of interacting with untrusted input and encourage cautious handling of new or modified Shipping Zone entries. Additionally, consider deploying web application firewalls (WAFs) with rules designed to detect and block XSS payloads targeting the affected fields. Finally, maintain a robust patch management process to ensure timely application of security updates.

Description

Craft Commerce is an ecommerce platform for Craft CMS. In versions from 4.0.0-RC1 to 4.10.0 and from 5.0.0 to 5.5.1, a stored XSS vulnerability in Craft Commerce allows attackers to execute malicious JavaScript in an administrator’s browser. This occurs because the Shipping Zone (Name & Description) fields in the Store Management section are not properly sanitized before being displayed in the admin panel. This issue has been patched in versions 4.10.1 and 5.5.2.

References

Community reviews

Loading reviews…