Skip to main content
VulnerabilityPublished

CVE-2026-25590: glpi-inventory-plugin · Cross-site Scripting

Affects glpi-inventory-pluginSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.5 Medium : upgrade to 1.6.6 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.6
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade glpi-inventory-plugin and glpi-project/glpi-inventory-plugin to 1.6.6.

Affected software

ProductAffectedFixed in
glpi-projectglpi-inventory-pluginAffected
  • <1.6.6
Fixed in
  • 1.6.6
GitHubglpi-project/glpi-inventory-pluginpkg:github/glpi-project/glpi-inventory-pluginOther threatsAffected
  • <1.6.6
Fixed in
  • 1.6.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-25590, organizations should immediately upgrade the GLPI Inventory Plugin to version 1.6.6 or later, where the vulnerability is patched. In addition to patching, administrators should enforce the principle of least privilege by restricting access to the GLPI interface and limiting high-privilege accounts to trusted personnel only. Implementing Content Security Policy (CSP) headers can help reduce the impact of XSS by restricting the execution of unauthorized scripts. Regularly auditing user accounts and monitoring for suspicious activities can detect potential exploitation attempts. Web application firewalls (WAFs) configured to detect and block reflected XSS payloads may provide an additional layer of defense. Finally, educating users about the risks of clicking on untrusted links or interacting with suspicious content within the GLPI environment can reduce the likelihood of successful exploitation.

Description

The GLPI Inventory Plugin handles network discovery, inventory, software deployment, and data collection for GLPI agents. Prior to 1.6.6, there is a reflected XSS vulnerability in task jobs. This vulnerability is fixed in 1.6.6.

References

Community reviews

Loading reviews…