Skip to main content
VulnerabilityPublished

CVE-2026-25610: MongoDB Server · Reachable Assertion

Affects MongoDB ServerSource CVE Database V5

0

Not known to be exploited · CVSS 7.1 High : upgrade to 8.0.13 or 7.0.29 soon.

Data as of 26 Oct 2026, 09:08 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.0.13, 7.0.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade MongoDB Server to 8.0.13 or 7.0.29.

Affected software

ProductAffectedFixed in
MongoDB IncMongoDB ServerAffected
  • >=8.0 <8.0.13
  • >=7.0 <7.0.29
Fixed in
  • 8.0.13
  • 7.0.29

AI-suggested

1. Upgrade MongoDB Server to a patched version once available from the vendor to address CVE-2026-25610. 2. If you cannot patch yet, restrict access to the $geoNear aggregation pipeline by limiting user privileges and roles to only those necessary, minimizing the number of authorized users who can execute such queries. 3. Implement monitoring and alerting for abnormal $geoNear query patterns or frequent assertion failures in MongoDB logs to detect potential exploitation attempts early. 4. Use network segmentation and firewall rules to limit database access to trusted hosts and applications, reducing exposure to potentially malicious authorized users. 5. Conduct regular audits of user roles and permissions to ensure least privilege principles are enforced, particularly for users with access to geospatial query capabilities. 6. Consider disabling or restricting the use of invalid index hints in queries through query validation or application-level input sanitization. 7. Maintain backups and have a robust incident response plan to recover quickly from potential denial-of-service incidents caused by this vulnerability.

Description

An authorized user may trigger a server crash by running a $geoNear pipeline with certain invalid index hints.

References

Community reviews

Loading reviews…