Skip to main content
CVE-2026-25957VulnerabilityPublished Updated

CVE-2026-25957: cube · Improper Handling of Exceptional Conditions

Affects cubeSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.5.13 or 1.4.2 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.13, 1.4.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade cube to 1.5.13 or 1.4.2.

Affected software

ProductAffectedFixed in
cube-jscubeAffected
  • >=1.1.17 <1.4.2
  • >=1.5.0 <1.5.13
Fixed in
  • 1.5.13
  • 1.4.2

AI-suggested

To mitigate CVE-2026-25957, European organizations should immediately upgrade all cube-js deployments to versions 1.4.2 or 1.5.13 or later, where the vulnerability is patched. In addition to patching, organizations should implement strict API access controls to limit the number of users with privileges sufficient to exploit this vulnerability. Employing network-level protections such as web application firewalls (WAFs) can help detect and block malformed requests targeting Cube API endpoints. Rate limiting and anomaly detection on API traffic can reduce the risk of denial of service attacks by limiting the impact of repeated malicious requests. Regularly auditing and monitoring API logs for unusual request patterns can provide early warning signs of exploitation attempts. Organizations should also ensure that their incident response plans include procedures for handling API service disruptions. Finally, educating developers and administrators about secure coding practices and proper exception handling can prevent similar vulnerabilities in custom extensions or integrations with cube-js.

Description

Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.

References

Community reviews

Loading reviews…