Skip to main content
VulnerabilityPublished Updated

CVE-2026-25958: cube · Reliance on Untrusted Inputs in a Security Decision

Affects cubeSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High · fixed in 1.5.13 : patch cube soon.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.13, 1.4.2, 1.0.14
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade cube to 1.5.13, 1.4.2 or 1.0.14.

Affected software

ProductAffectedFixed in
cube-jscubeAffected
  • >=1.5.0 <1.5.13
Fixed in
  • 1.5.13
cube-jscubeAffected
  • >=1.1.0 <1.4.2
Fixed in
  • 1.4.2
cube-jscubeAffected
  • >=0.27.19 <1.0.14
Fixed in
  • 1.0.14

AI-suggested

  1. Immediate upgrade of cube-js to patched versions 1.5.13, 1.4.2, or 1.0.14 depending on the deployment version.
  2. Restrict API token issuance and enforce strict token scope and expiration policies to minimize the risk of token misuse.
  3. Implement network-level access controls to limit exposure of cube-js endpoints to trusted internal networks or VPNs.
  4. Monitor API usage logs for unusual or anomalous requests that could indicate exploitation attempts.
  5. Employ runtime application self-protection (RASP) or web application firewalls (WAF) with custom rules to detect and block suspicious request patterns targeting privilege escalation.
  6. Conduct regular security audits and penetration testing focusing on authentication and authorization mechanisms within cube-js deployments.
  7. Educate developers and administrators on secure coding and configuration practices to prevent reliance on untrusted inputs in security decisions.
  8. Apply the principle of least privilege in API token generation and user roles to limit potential damage from compromised tokens.

Description

Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. This vulnerability is fixed in 1.5.13, 1.4.2, and 1.0.14.

References

Community reviews

Loading reviews…