Skip to main content
VulnerabilityPublished

CVE-2026-26003: labring FastGPT · Open Redirect

Affects labring FastGPTSource CVE Database V5

0

Not known to be exploited · CVSS 6.9 Medium : upgrade to 4.14.5-fix when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.14.5-fix
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade labring FastGPT to 4.14.5-fix.

Affected software

ProductAffectedFixed in
labringFastGPTAffected
  • >=4.14.0 <4.14.5-fix
Fixed in
  • 4.14.5-fix

AI-suggested

European organizations should immediately upgrade FastGPT to version 4.14.5-fix or later to remediate this vulnerability. Until patching is complete, network-level controls such as web application firewalls (WAFs) should be configured to restrict access to the FastGPT/api/plugin/ endpoints, allowing only trusted IP addresses or internal network segments. Monitoring and alerting should be enhanced for unusual API access patterns or plugin system crashes. Organizations should review plugin usage and backup plugin installation states regularly to enable rapid recovery if crashes occur. Security teams should educate users about phishing risks related to open redirects and implement email filtering to detect malicious URLs. Additionally, organizations should conduct penetration testing focused on API endpoints to identify similar vulnerabilities. Vendor communication channels should be monitored for further updates or patches. Finally, consider isolating FastGPT instances in segmented network zones to limit exposure.

Description

FastGPT is an AI Agent building platform. From 4.14.0 to 4.14.5, attackers can directly access the plugin system through FastGPT/api/plugin/xxx without authentication, thereby threatening the plugin system. This may cause the plugin system to crash and the loss of plugin installation status, but it will not result in key leakage. For older versions, as there are only operation interfaces for obtaining information, the impact is almost negligible. This vulnerability is fixed in 4.14.5-fix.

References

Community reviews

Loading reviews…