CVE-2026-26205: open-policy-agent opa-envoy-plugin · Incorrect Authorization
Affects open-policy-agent opa-envoy-pluginSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 1.13.2-envoy-2 soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.13.2-envoy-2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade open-policy-agent opa-envoy-plugin to 1.13.2-envoy-2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| open-policy-agentopa-envoy-plugin | Affected
| Fixed in
|
AI-suggested
Organizations should immediately upgrade the opa-envoy-plugin to version 1.13.2-envoy-2 or later, where the path parsing logic has been corrected. Until the upgrade is applied, administrators can implement strict input validation and normalization at the Envoy proxy or upstream web servers to reject or sanitize requests containing suspicious path patterns such as leading double slashes. Additionally, reviewing and tightening authorization policies to include explicit path normalization checks can reduce risk. Monitoring and logging should be enhanced to detect anomalous request paths and potential bypass attempts. Network-level protections such as Web Application Firewalls (WAFs) can be configured to block malformed paths. Finally, organizations should conduct thorough security assessments of their OPA policy enforcement points to ensure no other path interpretation inconsistencies exist.
Description
opa-envoy-plugun is a plugin to enforce OPA policies with Envoy. Versions prior to 1.13.2-envoy-2 have a vulnerability in how the `input.parsed_path` field is constructed. HTTP request paths are treated as full URIs when parsed; interpreting leading path segments prefixed with double slashes (`//`) as authority components, and therefore dropping them from the parsed path. This creates a path interpretation mismatch between authorization policies and backend servers, enabling attackers to bypass access controls by crafting requests where the authorization filter evaluates a different path than the one ultimately served. Version 1.13.2-envoy-2 fixes the issue.
References
- github.com/open-policy-agent/opa-envoy-plugin/security/advisories/GHSA-9f29-v6mm-pw6w (opens in a new tab)
- github.com/open-policy-agent/opa-envoy-plugin/commit/58c44d4ec408d5852d1d0287599e7d5c5e2bc5c3 (opens in a new tab)
- github.com/open-policy-agent/opa-envoy-plugin/releases/tag/v1.13.2-envoy-2 (opens in a new tab)