CVE-2026-26929: Apache Airflow · Incorrect Permissions
Affects Apache AirflowSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.1.8 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache Airflow to 3.1.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Airflow | Affected
| Fixed in
|
Mavenorg.apache.airflow/airflowpkg:maven/org.apache.airflow/airflowOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2026-26929, organizations should upgrade Apache Airflow to version 3.1.8 or later, where the vulnerability has been fixed by enforcing proper per-DAG authorization filtering in the DagVersion listing API. Until the upgrade can be performed, administrators should consider restricting access to the FastAPI endpoints to trusted users only, using network-level controls such as firewall rules or API gateway policies to limit exposure. Implementing strict role-based access control (RBAC) and monitoring API usage logs for unusual access patterns can help detect attempts to exploit this vulnerability. Additionally, reviewing and minimizing the number of users with API access reduces the attack surface. Organizations should also ensure that their Airflow deployment follows security best practices, including using secure authentication mechanisms, encrypting communications, and regularly auditing permissions. Finally, staying informed about updates from the Apache Software Foundation and applying security patches promptly is critical to maintaining a secure environment.
Description
Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.