Skip to main content
VulnerabilityPublished

CVE-2026-2695: TeamViewer DEX (On-Premises) · Improper Input Validation

Affects TeamViewer DEX (On-Premises)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 9.2 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade TeamViewer DEX (On-Premises) to 9.2.

Affected software

ProductAffectedFixed in
TeamViewerDEX (On-Premises)Affected
  • <9.2
Fixed in
  • 9.2

AI-suggested

If you cannot patch yet, restrict access to the platform to trusted users only and monitor for unusual activity from authenticated users with questioner privileges. Avoid granting unnecessary privileges to users. Follow updates from TeamViewer for any forthcoming patches or mitigations.

Description

CVE-2026-2695 is a command injection vulnerability in TeamViewer DEX Platform On-Premises versions prior to 9.2. It arises from improper input validation that allows authenticated users with at least questioner privileges to inject commands in specific instructions. Successful exploitation could enable execution of elevated commands on devices connected to the platform. The vulnerability has a CVSS score of 6.3, indicating medium severity. There are no known exploits in the wild at this time.

References

Community reviews

Loading reviews…