CVE-2026-26974: Tygo-van-den-Hurk Slyde · Untrusted Functionality Inclusion
Affects Tygo-van-den-Hurk SlydeSource CVE Database V5
Not known to be exploited · CVSS 7.6 High : upgrade to 0.0.5 soon.
Data as of 26 Oct 2026, 07:57 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.0.5
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade Tygo-van-den-Hurk Slyde to 0.0.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Tygo-van-den-HurkSlyde | Affected
| Fixed in
|
AI-suggested
1. Upgrade Slyde to version 0.0.5 or later immediately to ensure the vulnerability is patched. 2. Implement strict package management policies: audit all Node.js dependencies before installation, especially those containing .plugin.js files. 3. Use package integrity verification tools such as npm audit, npm ci with package-lock.json, or third-party solutions to detect and prevent malicious packages. 4. Restrict installation of packages to trusted registries and avoid installing packages from unverified sources. 5. Employ static code analysis and sandboxing techniques to analyze plugin files before execution. 6. Monitor runtime behavior of Slyde instances for unusual activity indicative of code execution attacks. 7. Educate developers and DevOps teams about the risks of installing untrusted packages and the importance of dependency hygiene. 8. Consider isolating Slyde execution environments using containerization or least privilege principles to limit impact if exploitation occurs. 9. Review and restrict file import patterns in custom Node.js applications to avoid broad wildcard imports from untrusted directories.
Description
Slyde is a program that creates animated presentations from XML. In versions 0.0.4 and below, Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file can execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. This issue has been fixed in version 0.0.5. To workaround this issue, users can audit and restrict which packages are installed in node_modules.