Skip to main content
VulnerabilityPublished

CVE-2026-27126: craftcms cms · Cross-site Scripting

Affects craftcms cmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 5.8.23 or 4.16.19 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.8.23, 4.16.19
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade craftcms cms to 5.8.23 or 4.16.19.

Affected software

ProductAffectedFixed in
craftcmscmsAffected
  • >=5.0.0-RC1 <5.8.23
Fixed in
  • 5.8.23
craftcmscmsAffected
  • >=4.5.0-RC1 <4.16.19
Fixed in
  • 4.16.19

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade Craft CMS to version 4.16.19 or later, or 5.8.23 or later, where the vulnerability is patched.
  2. Disable the allowAdminChanges setting in production environments as recommended by Craft CMS security guidelines to reduce the attack surface.
  3. Enforce strict administrator account management, including strong authentication, least privilege principles, and regular auditing of admin activities.
  4. Implement Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers.
  5. Regularly review and sanitize all user-generated content, especially when using components like editableTable.twig with html column types.
  6. Monitor logs and CMS activity for unusual behavior indicative of attempted exploitation.
  7. Educate administrators about the risks of enabling development features in production and the importance of applying security patches promptly.

Description

Craft is a content management system (CMS). In versions 4.5.0-RC1 through 4.16.18 and 5.0.0-RC1 through 5.8.22, a stored Cross-site Scripting (XSS) vulnerability exists in the `editableTable.twig` component when using the `html` column type. The application fails to sanitize the input, allowing an attacker to execute arbitrary JavaScript when another user views a page with the malicious table field. In order to exploit the vulnerability, an attacker must have an administrator account, and `allowAdminChanges` must be enabled in production, which is against Craft's security recommendations. Versions 4.16.19 and 5.8.23 patch the issue.

References

Community reviews

Loading reviews…