CVE-2026-27589: caddyserver caddy · Cross-Site Request Forgery (CSRF)
Affects caddyserver caddySource CVE Database V5
Public exploit available · CVSS 6.9 Medium : upgrade to 2.11.1 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.11.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 24 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade caddy and caddyserver/caddy to 2.11.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| caddyservercaddy | Affected
| Fixed in
|
GitHubcaddyserver/caddypkg:github/caddyserver/caddyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate this vulnerability, organizations should upgrade Caddy to version 2.11.1 or later, which includes the fix enforcing origin checks on the admin API. If immediate upgrade is not feasible, administrators should enable the 'enforce_origin' configuration option to restrict cross-origin requests to the admin endpoint. Additionally, restricting access to the admin API interface to trusted hosts only (e.g., via firewall rules or network segmentation) can reduce exposure. Monitoring and logging admin API access can help detect suspicious configuration changes. Avoid exposing the admin API to untrusted networks or the public internet. Implementing web application firewalls (WAFs) that can detect and block CSRF attempts targeting the admin API may provide additional protection. Finally, educating users about the risks of visiting untrusted websites while logged into systems with exposed admin APIs can reduce the likelihood of exploitation.
Description
Caddy is an extensible server platform that uses TLS by default. Prior to version 2.11.1, the local caddy admin API (default listen `127.0.0.1:2019`) exposes a state-changing `POST /load` endpoint that replaces the entire running configuration. When origin enforcement is not enabled (`enforce_origin` not configured), the admin endpoint accepts cross-origin requests (e.g., from attacker-controlled web content in a victim browser) and applies an attacker-supplied JSON config. This can change the admin listener settings and alter HTTP server behavior without user intent. Version 2.11.1 contains a fix for the issue.
References
- github.com/caddyserver/caddy/security/advisories/GHSA-879p-475x-rqh2 (opens in a new tab)
- github.com/caddyserver/caddy/releases/tag/v2.11.1 (opens in a new tab)
- github.com/user-attachments/files/25079818/poc.zip (opens in a new tab)
- github.com/user-attachments/files/25079820/PR_DESCRIPTION.md (opens in a new tab)