Skip to main content
VulnerabilityPublished

CVE-2026-27639: dbarzin mercator · Cross-site Scripting

Affects dbarzin mercatorSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High : upgrade to 2026.02.22 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.02.22
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mercator and dbarzin/mercator to 2026.02.22.

Affected software

ProductAffectedFixed in
dbarzinmercatorAffected
  • <2026.02.22
Fixed in
  • 2026.02.22
GitHubdbarzin/mercatorpkg:github/dbarzin/mercatorOther threatsAffected
  • <2026.02.22
Fixed in
  • 2026.02.22

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade Mercator installations to version 2026.02.22 or later, which includes the fix for this vulnerability.
  2. Implement strict input validation and output encoding in all user-supplied fields, especially those rendered with Blade templates, to prevent injection of executable code.
  3. Enforce the principle of least privilege by reviewing and restricting User role permissions to minimize the ability to inject malicious content.
  4. Monitor application logs and user activities for unusual input patterns or script injection attempts.
  5. Educate users and administrators about the risks of stored XSS and encourage cautious handling of user-generated content.
  6. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers.
  7. Conduct regular security assessments and code reviews focusing on template rendering and input handling.
  8. Consider implementing multi-factor authentication to reduce the risk of compromised user accounts being exploited to inject malicious payloads.

Description

Mercator is an open source web application designed to enable mapping of information systems. A stored Cross-Site Scripting (XSS) vulnerability exists in Mercator prior to version 2026.02.22 due to the use of unescaped Blade directives (`{!! !!}`) in display templates. An authenticated user with the User role can inject arbitrary JavaScript payloads into fields such as "contact point" when creating or editing entities. The payload is then executed in the browser of any user who views the affected page, including administrators. Version 2026.02.22 fixes the vulnerability.

References

Community reviews

Loading reviews…