Skip to main content
VulnerabilityPublished

CVE-2026-8606: GitHub Enterprise Server · Server-Side Request Forgery (SSRF)

Affects GitHub Enterprise ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.0 High : upgrade to 3.21.1 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.21.1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade GitHub Enterprise Server to 3.21.1.

Affected software

ProductAffectedFixed in
GitHubEnterprise ServerAffected
  • >=3.21.0 <3.21.1
  • >=3.20.0 <3.20.3
  • >=3.19.0 <3.19.7
  • >=3.18.0 <3.18.10
  • >=3.17.0 <3.17.16
  • >=3.16.0 <3.16.19
Fixed in
  • 3.21.1

AI-suggested

Fixes for this vulnerability are available in GitHub Enterprise Server versions 3.20.3, 3.19.7, 3.18.10, 3.17.16, and 3.16.19. Users should upgrade affected instances to one of these versions or later to remediate the issue. Since this is not a cloud service, remediation depends on applying these official patches. Patch status is confirmed by the vendor advisory embedded in the description.

Description

A Server-Side Request Forgery (SSRF) vulnerability was identified in GitHub Enterprise Server that allowed an attacker to cause the server to issue HTTP requests to internal services via the security advisories package lookup feature. By directing requests to an internal management service and measuring response timing, an attacker could infer the values of sensitive environment variables, including signing secrets and private keys. Exploitation required GitHub Packages to be enabled; on instances not running in private mode the vulnerability was exploitable without authentication, otherwise any authenticated user could exploit it. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21.1 and was fixed in versions 3.20.3, 3.19.7, 3.18.10, 3.17.16, and 3.16.19. This vulnerability was reported via the GitHub Bug Bounty program.

References

Community reviews

Loading reviews…