CVE-2026-27744: SPIP tickets · Code Injection
Affects SPIP ticketsSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 4.3.3 as a priority.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.3.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade SPIP tickets to 4.3.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SPIPtickets | Affected
| Fixed in
|
AI-suggested
Organizations should urgently upgrade the SPIP tickets plugin to version 4.3.3 or later once available to address this vulnerability. If you cannot patch yet, administrators should consider disabling the forum preview feature on public ticket pages to prevent untrusted input rendering. Implementing web application firewalls (WAFs) with custom rules to detect and block suspicious payloads targeting the #ENV** rendering pattern can provide temporary protection. Restricting access to ticketing interfaces by IP whitelisting or VPN can reduce exposure. Reviewing and hardening template rendering configurations to enforce output filtering or sanitization of user inputs is critical. Monitoring web server logs for unusual requests or payloads resembling code injection attempts can aid early detection. Conducting regular security assessments and penetration tests focusing on template injection vectors will help identify residual risks. Finally, organizations should maintain an incident response plan to quickly contain and remediate any exploitation attempts.
Description
The SPIP tickets plugin versions prior to 4.3.3 contain an unauthenticated remote code execution vulnerability in the forum preview handling for public ticket pages. The plugin appends untrusted request parameters into HTML that is later rendered by a template using unfiltered environment rendering (#ENV**), which disables SPIP output filtering. As a result, an unauthenticated attacker can inject crafted content that is evaluated through SPIP's template processing chain, leading to execution of code in the context of the web server.
References
- chocapikk.com/posts/2026/spip-plugins-vulnerabilities/ (opens in a new tab)
- blog.spip.net/Mise-a-jour-de-securite-sortie-de-SPIP-4-4-10.html (opens in a new tab)
- plugins.spip.net/tickets (opens in a new tab)
- git.spip.net/spip-contrib-extensions/tickets/-/commit/869935b6687822ed79ad5477626a664d8ea6dcf7 (opens in a new tab)
- vulncheck.com/advisories/spip-tickets-unauthenticated-rce (opens in a new tab)