CVE-2026-27804: parse-server · Weak Cryptography
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 9.3.1-alpha.4 or 8.6.3 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.3.1-alpha.4, 8.6.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse-server to 9.3.1-alpha.4 or 8.6.3; parse-community/parse-server to 8.6.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should immediately upgrade parse-server to version 8.6.3 or later, or 9.1.1-alpha.4 or later, where the vulnerability is fixed. If immediate upgrade is not feasible, disable Google authentication temporarily to prevent exploitation. Review authentication logs for suspicious login attempts or anomalies indicative of token forgery. Implement additional monitoring and alerting on authentication events. Consider deploying Web Application Firewalls (WAFs) with rules to detect and block JWT tokens with 'alg: none' or malformed tokens. Conduct a thorough audit of user accounts linked to Google authentication for unauthorized access. Educate developers and administrators on secure JWT handling and the risks of trusting JWT header algorithms. Finally, ensure that third-party libraries handling JWT validation are up to date and configured to reject insecure algorithms and unknown key IDs.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.3 and 9.1.1-alpha.4, an unauthenticated attacker can forge a Google authentication token with `alg: "none"` to log in as any user linked to a Google account, without knowing their credentials. All deployments with Google authentication enabled are affected. The fix in versions 8.6.3 and 9.1.1-alpha.4 hardcodes the expected `RS256` algorithm instead of trusting the JWT header, and replaces the Google adapter's custom key fetcher with `jwks-rsa` which rejects unknown key IDs. As a workaround, dsable Google authentication until upgrading is possible.
References
- github.com/parse-community/parse-server/security/advisories/GHSA-4q3h-vp4r-prv2 (opens in a new tab)
- github.com/parse-community/parse-server/commit/9b94083accb7f3e72c6b8126c195c7a03dd2dfd7 (opens in a new tab)
- github.com/parse-community/parse-server/commit/9d5942d50e55c822924c27b05aa98f1393e7a330 (opens in a new tab)
- github.com/parse-community/parse-server/releases/tag/8.6.3 (opens in a new tab)
- github.com/parse-community/parse-server/releases/tag/9.3.1-alpha.4 (opens in a new tab)