CVE-2026-27828: everest-core · Use After Free
Affects everest-coreSource CVE Database V5
Public exploit available · CVSS 5.5 Medium : upgrade to 2026.02.0 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.02.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 26 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade everest-core and everest/everest-core to 2026.02.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| EVeresteverest-core | Affected
| Fixed in
|
GitHubeverest/everest-corepkg:github/everest/everest-coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to EVerest everest-core version 2026.02.0 or later, which contains the official patch for this vulnerability. No other mitigation is indicated or required according to the available information.
Description
CVE-2026-27828 is a use-after-free vulnerability in the EVerest everest-core EV charging software stack prior to version 2026.02.0. The issue occurs in the ISO15118_chargerImpl::handle_session_setup function, which uses a freed v2g_ctx object when ISO15118 initialization fails, such as when no IPv6 link-local address is present. An attacker with MQTT access can remotely crash the EVSE process by issuing a session_setup command under these conditions. The vulnerability has a medium severity with a CVSS score of 5.5. Version 2026.02.0 contains a patch that addresses this issue.