CVE-2026-27890: FirebirdSQL firebird · Memory Buffer Overflow
Affects FirebirdSQL firebirdSource CVE Database V5
Not known to be exploited · CVSS 8.2 High · fixed in 5.0.4 : patch FirebirdSQL firebird soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.0.4, 4.0.7, 3.0.14
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade firebird and firebirdsql/firebird to 5.0.4, 4.0.7 or 3.0.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FirebirdSQLfirebird | Affected
| Fixed in
|
| FirebirdSQLfirebird | Affected
| Fixed in
|
| FirebirdSQLfirebird | Affected
| Fixed in
|
GitHubfirebirdsql/firebirdpkg:github/firebirdsql/firebirdOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in FirebirdSQL versions 5.0.4, 4.0.7, and 3.0.14. Users should upgrade to these or later versions to remediate the issue. Patch status is confirmed by the vendor's versioning information. No other mitigation or workaround is indicated.
Description
Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, when processing CNCT_specific_data segments during authentication, the server assumes segments arrive in strictly ascending order. If segments arrive out of order, the Array class's grow() method computes a negative size value, causing a SIGSEGV crash. An unauthenticated attacker who knows only the server's IP and port can exploit this to crash the server. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.
References
- github.com/FirebirdSQL/firebird/security/advisories/GHSA-6crx-4g37-7j49 (opens in a new tab)
- github.com/FirebirdSQL/firebird/releases/tag/v3.0.14 (opens in a new tab)
- github.com/FirebirdSQL/firebird/releases/tag/v4.0.7 (opens in a new tab)
- github.com/FirebirdSQL/firebird/releases/tag/v5.0.4 (opens in a new tab)