Skip to main content
VulnerabilityPublished

CVE-2026-27963: advplyr audiobookshelf · Cross-site Scripting

Affects advplyr audiobookshelfSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 2.32.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.32.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade audiobookshelf and advplyr/audiobookshelf to 2.32.0.

Affected software

ProductAffectedFixed in
advplyraudiobookshelfAffected
  • <2.32.0
Fixed in
  • 2.32.0
GitHubadvplyr/audiobookshelfpkg:github/advplyr/audiobookshelfOther threatsAffected
  • <2.32.0
Fixed in
  • 2.32.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, organizations should immediately upgrade Audiobookshelf installations to version 2.32.0 or later, where the issue is patched. Until upgrading is possible, restrict library modification privileges strictly to trusted administrators and users to minimize the risk of malicious metadata injection. Implement strong authentication and access control policies to prevent unauthorized privilege escalation. Additionally, consider deploying Content Security Policy (CSP) headers to limit the execution of unauthorized scripts in browsers accessing the application. Regularly audit library metadata for suspicious or unexpected content that could indicate attempted exploitation. Educate users about the risks of interacting with untrusted content and monitor logs for unusual activity related to library modifications. Finally, maintain up-to-date backups and incident response plans to quickly recover from any compromise.

Description

Audiobookshelf is a self-hosted audiobook and podcast server. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.32.0 of the Audiobookshelf web application that allows arbitrary JavaScript execution through malicious library metadata. Attackers with library modification privileges can execute code in victim users' browsers, potentially leading to session hijacking and data exfiltration. Version 2.32.0 contains a patch for the issue.

References

Community reviews

Loading reviews…