CVE-2026-27977: vercel next.js · Missing Origin Validation in WebSockets
Affects vercel next.jsSource CVE Database V5
Not known to be exploited · CVSS 2.3 Low : upgrade to 16.1.7 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.1.7
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade next.js and next to 16.1.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vercelnext.js | Affected
| Fixed in
|
npmnextpkg:npm/nextOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Upgrade Next.js to version 16.1.7 or later, where the vulnerability is fixed by proper origin validation.
- Ensure that development servers running 'next dev' are not exposed to untrusted networks or the public internet. Restrict access to trusted internal networks only.
- Configure network-level controls such as firewalls or reverse proxies to block WebSocket upgrade requests to '/_next/webpack-hmr' endpoints when the 'Origin' header is 'null'.
- If immediate upgrade is not possible, implement strict access controls and monitoring on development servers to detect unauthorized WebSocket connections.
- Educate developers about the risks of exposing development servers and enforce policies to avoid public exposure.
- Review and configure the 'allowedDevOrigins' setting carefully to restrict allowed origins and prevent unauthorized connections.
- Regularly audit development environments for exposure and apply security best practices to isolate development infrastructure from untrusted sources.
Description
CVE-2026-27977 is a low-severity vulnerability affecting development mode in Next.js versions 16.0.1 up to but not including 16.1.7. It involves missing origin validation in WebSocket connections used for Hot Module Replacement (HMR) during development. Specifically, the dev server's WebSocket endpoint could treat an 'Origin: null' header as a bypass, allowing attacker-controlled or sandboxed contexts to connect unexpectedly if the dev server is exposed to untrusted networks. This could enable an attacker to interact with development WebSocket traffic, potentially leaking sensitive information or manipulating the development environment. The issue is fixed in version 16.