Skip to main content
VulnerabilityPublished

CVE-2026-42404: Apache Neethi · Server-Side Request Forgery (SSRF)

Affects Apache NeethiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.2.2 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache to 3.2.2.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache NeethiAffected
  • <3.2.2
Fixed in
  • 3.2.2
MavenApache Software Foundation/org.apache.neethi:neethipkg:maven/Apache Software Foundation/org.apache.neethi:neethiOther threatsAffected
  • <3.2.2
Fixed in
  • 3.2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Neethi to version 3.2.2 or later, which enforces URI restrictions and blocks unsafe addresses, effectively mitigating the SSRF vulnerability. No other mitigation steps are indicated or required according to the available data.

Description

Apache Neethi does not impose any restrictions on URIs when manually fetching remote policy references through the PolicyReference API. When an application explicitly calls the API to retrieve a policy from a remote URI, an outbound request is made for arbitrary protocols and internal IP adddresses. From 3.2.2, only http or https URIs are allowed, and link-local/multicast/any-local addresses are forbidden. Users are recommended to upgrade to version 3.2.2, which fixes this issue.

References

Community reviews

Loading reviews…