Skip to main content
VulnerabilityPublished

CVE-2026-28563: Apache Airflow · Incorrect Permissions

Affects Apache AirflowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.3 Medium : upgrade to 3.1.8 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache Airflow to 3.1.8.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache AirflowAffected
  • >=3.0.0 <3.1.8
Fixed in
  • 3.1.8
PyPIapache-airflowpkg:pypi/apache-airflowOther threatsAffected
  • =3.0.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-28563, organizations should upgrade Apache Airflow to version 3.1.8 or later, where the vulnerability has been fixed by enforcing proper access control filtering on the /ui/dependencies endpoint. Until upgrading is possible, administrators should review and restrict the assignment of the DAG Dependencies permission to only trusted users who require it for their role, minimizing the number of users who can exploit this flaw. Implement network segmentation and access controls to limit access to the Airflow UI and API endpoints to authorized personnel only. Monitor logs and audit access to the /ui/dependencies endpoint for unusual or unauthorized enumeration activities. Employ strong authentication mechanisms and consider multi-factor authentication to reduce the risk of compromised credentials being used to exploit this vulnerability. Additionally, conduct regular security reviews of Airflow permissions and configurations to ensure least privilege principles are enforced. If feasible, disable or restrict access to the /ui/dependencies endpoint temporarily as a stopgap measure. Finally, maintain awareness of updates from the Apache Software Foundation and apply security patches promptly.

Description

Apache Airflow versions 3.1.0 through 3.1.7 /ui/dependencies endpoint returns the full DAG dependency graph without filtering by authorized DAG IDs. This allows an authenticated user with only DAG Dependencies permission to enumerate DAGs they are not authorized to view. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.

References

Community reviews

Loading reviews…