Skip to main content
VulnerabilityPublished

CVE-2026-29080: rucio · SQL Injection

Affects rucioSource GCVE Database

0

Not known to be exploited · CVSS 9.4 Critical · fixed in 40.1.1 : patch rucio as a priority.

Data as of 27 Oct 2026, 02:11 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 40.1.1, 39.4.2, 38.5.5 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade rucio to 40.1.1, 39.4.2, 38.5.5 or 35.8.5.

Affected software

ProductAffectedFixed in
rucio rucioAffected
  • >=1.27.0 <35.8.5
  • >=35.9.0 <38.5.5
  • >=38.6.0 <39.4.2
  • >=40.0.0 <40.1.1
Fixed in
  • 35.8.5
  • 38.5.5
  • 39.4.2
  • 40.1.1

AI-suggested

This vulnerability has been fixed in Rucio versions 35.8.5, 38.5.5, 39.4.2, and 40.1.1. Users should upgrade to one of these fixed versions to remediate the issue. No other mitigation or workaround is indicated by the vendor advisory.

Description

CVE-2026-29080 is a critical SQL injection vulnerability in Rucio's FilterEngine.create_sqla_query() method affecting Oracle database deployments. Authenticated users can exploit this flaw via the DID search API to execute arbitrary SQL commands, potentially compromising the entire backend database including sensitive authentication tokens and data identifiers. The vulnerability affects Rucio versions from 1.27.0 up to but not including 35.8.5, 38.5.5, 39.4.2, and 40.1.1, where it has been fixed. PostgreSQL and MySQL deployments are not affected. The issue arises because attacker-controlled input is directly interpolated into raw SQL text without parameterization, enabling full database compromise.

References

Community reviews

Loading reviews…