Skip to main content
VulnerabilityPublished

CVE-2026-29090: rucio · SQL Injection

Affects rucioSource GCVE Database

0

Not known to be exploited · CVSS 9.0 Critical · fixed in 40.1.1 : patch rucio as a priority.

Data as of 27 Oct 2026, 02:11 UTC

CVSS 4.0 base score
9.0Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 40.1.1, 39.4.2, 38.5.5 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade rucio to 40.1.1, 39.4.2, 38.5.5 or 35.8.5.

Affected software

ProductAffectedFixed in
rucio rucioAffected
  • >=1.30.0 <35.8.5
  • >=35.9.0 <38.5.5
  • >=38.6.0 <39.4.2
  • >=40.0.0 <40.1.1
Fixed in
  • 35.8.5
  • 38.5.5
  • 39.4.2
  • 40.1.1

AI-suggested

This vulnerability has been fixed in Rucio versions 35.8.5, 38.5.5, 39.4.2, and 40.1.1. Users should upgrade to one of these fixed versions to remediate the issue. There is no indication of alternative mitigations or workarounds. Ensure that the postgres_meta metadata plugin is used only in updated versions.

Description

A critical SQL injection vulnerability exists in Rucio versions 1.30.0 and later before 35.8.5, 38.5.5, 39.4.2, and 40.1.1. The flaw is in the FilterEngine.create_postgres_query() function when the postgres_meta metadata plugin is used. Authenticated users can exploit this via the DID search endpoint to execute arbitrary SQL commands on the PostgreSQL metadata database. This can lead to exposure or modification of sensitive data, file access, or even code execution depending on database privileges. The vulnerability has been fixed in versions 35.8.5, 38.5.5, 39.4.2, and 40.1.1.

References

Community reviews

Loading reviews…