Skip to main content
VulnerabilityPublished

CVE-2026-29173: craftcms commerce · Cross-site Scripting

Affects craftcms commerceSource CVE Database V5

0
Compare

Public exploit available · CVSS 1.9 Low : upgrade to 5.5.3 or 4.10.2 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
1.9Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.3, 4.10.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade commerce and craftcms/commerce to 5.5.3 or 4.10.2.

Affected software

ProductAffectedFixed in
craftcmscommerceAffected
  • >=5.0.0 <5.5.3
Fixed in
  • 5.5.3
craftcmscommerceAffected
  • >=4.0.0 <4.10.2
Fixed in
  • 4.10.2
GitHubcraftcms/commercepkg:github/craftcms/commerceOther threatsAffected
  • <4.10.2
  • >=4.0.0 <4.10.2
  • <5.5.3
  • >=5.0.0 <5.5.3
Fixed in
  • 4.10.2
  • 5.5.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should upgrade Craft Commerce to versions 4.10.2 or 5.5.3 or later, where this vulnerability is fixed. Until upgrades can be performed, administrators should restrict permissions to update order statuses to only highly trusted users to reduce the risk of malicious input. Implementing strict input validation and output encoding on all user-supplied data fields within the CMS can further mitigate XSS risks. Additionally, enabling Content Security Policy (CSP) headers can help limit the impact of any injected scripts by restricting script execution sources. Regularly auditing user roles and permissions to minimize privilege exposure and monitoring logs for suspicious activity related to order status updates are recommended. Educating users about the risks of XSS and encouraging cautious behavior when interacting with order management interfaces can also reduce exploitation likelihood. Finally, applying web application firewalls (WAFs) with rules targeting XSS payloads may provide an additional layer of defense.

Description

Craft Commerce is an ecommerce platform for Craft CMS. Prior to 4.10.2 and 5.5.3, a stored XSS vulnerability exists when a user tries to update the Order Status from the Commerce Orders Table. The Order Status Name is rendered without proper escaping, allowing script execution to occur. This vulnerability is fixed in 4.10.2 and 5.5.3.

References

Community reviews

Loading reviews…