Skip to main content
VulnerabilityPublished Updated

CVE-2026-30835: parse-server · Generation of Error Message Containing Sensitive Information

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 9.5.0-alpha.6 or 8.6.7 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5.0-alpha.6, 8.6.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.5.0-alpha.6 or 8.6.7; parse-community/parse-server to 8.6.7.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • <9.5.0-alpha.6
Fixed in
  • 9.5.0-alpha.6
parse-communityparse-serverAffected
  • <8.6.7
Fixed in
  • 8.6.7
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.7
  • =9.5.0-alpha.6
Fixed in
  • 8.6.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should upgrade parse-server to version 8.6.7 or later (or 9.5.0-alpha.6 or later) where this vulnerability is patched. In addition to upgrading, administrators should implement strict input validation and sanitization on all query parameters, especially those involving regular expressions. Limiting the exposure of the parse-server API to trusted clients and networks reduces the risk of exploitation. Configuring error handling to avoid returning detailed internal error information to clients is critical; generic error messages should be used instead. Monitoring and logging unusual or malformed query requests can help detect exploitation attempts. Finally, reviewing and tightening database permissions and network segmentation can limit the impact if an attacker gains additional footholds.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.7 and 9.5.0-alpha.6, malformed $regex query parameter (e.g. [abc) causes the database to return a structured error object that is passed unsanitized through the API response. This leaks database internals such as error messages, error codes, code names, cluster timestamps, and topology details. The vulnerability is exploitable by any client that can send query requests, depending on the deployment's permission configuration. This issue has been patched in versions 8.6.7 and 9.5.0-alpha.6.

References

Community reviews

Loading reviews…