CVE-2026-30938: parse-server · Protection Mechanism Failure
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 9.5.1-alpha.1 or 8.6.12 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.5.1-alpha.1, 8.6.12
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse-server to 9.5.1-alpha.1 or 8.6.12; parse-server to 8.6.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-serverpkg:npm/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should immediately upgrade parse-server to version 8.6.12 or later, or 9.5.1-alpha.1 or later, where the vulnerability is patched. In addition to upgrading, developers should implement Cloud Code beforeSave triggers that perform deep validation of incoming request payloads to detect and block prohibited keywords regardless of their nesting level. This custom validation should recursively scan all nested objects and arrays to ensure no bypass is possible. Regularly audit and update the requestKeywordDenylist entries to cover all sensitive keywords relevant to the application context. Employ runtime monitoring and logging to detect anomalous request patterns that may indicate exploitation attempts. Restrict access to parse-server endpoints using network controls such as IP whitelisting or API gateways to reduce exposure. Finally, maintain an incident response plan to quickly address any suspicious activity related to this vulnerability.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.12 and 9.5.1-alpha.1, the requestKeywordDenylist security control can be bypassed by placing any nested object or array before a prohibited keyword in the request payload. This is caused by a logic bug that stops scanning sibling keys after encountering the first nested value. Any custom requestKeywordDenylist entries configured by the developer are equally by-passable using the same technique. All Parse Server deployments are affected. The requestKeywordDenylist is enabled by default. This vulnerability is fixed in 8.6.12 and 9.5.1-alpha.1. Use a Cloud Code beforeSave trigger to validate incoming data for prohibited keywords across all classes.