Skip to main content
VulnerabilityPublished

CVE-2026-30941: parse-server · Improper Neutralization of Special Elements in Data Query Logic

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 9.5.2-alpha.1 or 8.6.14 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5.2-alpha.1, 8.6.14
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.5.2-alpha.1 or 8.6.14; parse-server to 8.6.14.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.5.2-alpha.1
Fixed in
  • 9.5.2-alpha.1
parse-communityparse-serverAffected
  • <8.6.14
Fixed in
  • 8.6.14
npmparse-serverpkg:npm/parse-serverOther threatsAffected
  • <8.6.14
Fixed in
  • 8.6.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade parse-server to version 8.6.14 or later, or 9.5.2-alpha.1 or later, where the vulnerability is patched. If immediate upgrade is not feasible, temporarily disable email verification and password reset features to reduce exposure. Review and audit all configurations related to emailVerifyTokenReuseIfValid, disabling it if not strictly necessary. Implement additional input validation and sanitization at the application layer to prevent injection of MongoDB operators in token fields. Monitor logs for unusual query patterns or repeated token requests that may indicate exploitation attempts. Employ network-level protections such as Web Application Firewalls (WAFs) configured to detect and block NoSQL injection payloads targeting these endpoints. Conduct thorough security testing and code reviews focusing on query parameter handling to prevent similar injection flaws. Finally, educate development teams on secure coding practices related to NoSQL query construction and input validation.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.14 and 9.5.2-alpha.1, NoSQL injection vulnerability allows an unauthenticated attacker to inject MongoDB query operators via the token field in the password reset and email verification resend endpoints. The token value is passed to database queries without type validation and can be used to extract password reset and email verification tokens. Any Parse Server deployment using MongoDB with email verification or password reset enabled is affected. When emailVerifyTokenReuseIfValid is configured, the email verification token can be fully extracted and used to verify a user's email address without inbox access. This vulnerability is fixed in 8.6.14 and 9.5.2-alpha.1.

References

Community reviews

Loading reviews…