CVE-2026-30966: parse-server · Improper Access Control
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 10.0 Critical : upgrade to 9.5.2-alpha.7 or 8.6.20 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.3% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.5.2-alpha.7, 8.6.20
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 10 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse-server to 9.5.2-alpha.7 or 8.6.20; parse-community/parse-server to 8.6.20.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should immediately upgrade parse-server to version 9.5.2-alpha.7 or 8.6.20 or later, where this vulnerability is fixed. Until upgrading, restrict network access to parse-server APIs to trusted clients only, ideally behind VPNs or firewalls. Implement strict monitoring and logging of API access to detect unusual activities related to role membership or Relation field modifications. Review and rotate application keys and master keys to limit exposure. Consider implementing additional application-layer access controls or API gateways that enforce stricter authentication and authorization checks beyond the default parse-server mechanisms. Conduct thorough audits of role memberships and permissions to identify any unauthorized changes. Finally, educate development and operations teams about the risks of exposing internal tables and the importance of timely patching.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.7 and 8.6.20, Parse Server's internal tables, which store Relation field mappings such as role memberships, can be directly accessed via the REST API or GraphQL API by any client using only the application key. No master key is required. An attacker can create, read, update, or delete records in any internal relationship table. Exploiting this allows the attacker to inject themselves into any Parse Role, gaining all permissions associated with that role, including full read, write, and delete access to classes protected by role-based Class-Level Permissions (CLP). Similarly, writing to any such table that backs a Relation field used in a pointerFields CLP bypasses that access control. This vulnerability is fixed in 9.5.2-alpha.7 and 8.6.20.