Skip to main content
VulnerabilityPublished

CVE-2026-30977: lihaohong6 RenderBlocking · Cross-site Scripting

Affects lihaohong6 RenderBlockingSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.0 Low : upgrade to 0.1.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
2.0Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.1.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade RenderBlocking and lihaohong6/RenderBlocking to 0.1.1.

Affected software

ProductAffectedFixed in
lihaohong6RenderBlockingAffected
  • <0.1.1
Fixed in
  • 0.1.1
GitHublihaohong6/RenderBlockingpkg:github/lihaohong6/RenderBlockingOther threatsAffected
  • <0.1.1
Fixed in
  • 0.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade the RenderBlocking extension to version 0.1.1 or later, where the vulnerability is fixed. Administrators should audit user privileges to ensure that only trusted users have editsitecss rights, minimizing the risk of malicious input. Additionally, implement strict content security policies (CSP) to restrict script execution sources, which can reduce the impact of XSS attacks. Regularly review and sanitize all inputs related to CSS and JavaScript editing interfaces. Employ monitoring and alerting for unusual administrative activities or unexpected content changes. Finally, educate administrators about the risks of injecting untrusted content and enforce multi-factor authentication (MFA) to protect privileged accounts.

Description

CVE-2026-30977 is a stored cross-site scripting (XSS) vulnerability in the RenderBlocking MediaWiki extension versions prior to 0.1.1. It affects configurations where $wgRenderBlockingInlineAssets is set to true and requires the user to have editsitecss rights. The vulnerability allows an attacker with these privileges to inject malicious scripts that are stored and executed in the context of other users viewing the affected pages. Although the CVSS score is low (2.0), exploitation requires high privileges and user interaction. The issue is fixed in version 0.1.1 of RenderBlocking.

References

Community reviews

Loading reviews…